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Apply Text Formats



Fonts
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In Excel, the terms font and typeface are often confused, but they have distinct meanings. 
A font refers to the physical collection of characters—whether stored digitally in a file or as 
metal pieces in traditional printing—while a typeface is the overall design and appearance 
of those characters. In practice, the word font is often used interchangeably to mean both. 
Changing the font in a worksheet alters how letters, numbers, punctuation, and symbols 
look. Different fonts and font sizes can highlight certain data, improve readability, or simply 
make worksheets more visually appealing. Beyond appearance, fonts also affect the 
spacing between characters, which can influence how neatly and clearly your data is 
presented.



The Font Group
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The Font group on the Home tab provides you with access to the most commonly used 
commands for adjusting the fonts in your worksheets. From here you can change the font 
type, size, and color in your worksheets. You will also find commands for applying 
particular formatting to your fonts, such as bolding, italics, and underlining.



The Font Group
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Font Group Command Use This To

Font drop-down menu Change the font type.

Font Size drop-down menu Change the font size. You can either select one of the predefined font 
sizes from the drop-down menu or manually type the desired font size.

Increase Font Size button Cycle up through the predefined font sizes to make your worksheet font 
bigger.

Decrease Font Size button Cycle down through the predefined font sizes to make your worksheet 
font smaller.

Bold button Bold the currently selected text.

Italic button Italicize the currently selected text.

Underline button Underline the currently selected text.

Font Color drop-down menu Change the color of the currently selected text.



Live Preview
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Live Preview is a dynamic feature of Excel 2021 that allows you to see what a particular 
formatting change will look like before you actually apply it. This feature can help you 
quickly assess which particular formatting you would like to apply to the content and 
objects in your worksheets. The Live Preview feature works with a number of different 
formatting options, including font formatting, cell styles, and Paste command options.



The Format Cells Dialog Box
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You can access all of the commands and options for 
formatting your worksheet fonts, along with a wide 
variety of other formatting options, in the Format Cells 
dialog box. Think of this dialog box as an extension of 
the common formatting commands you will find in the 
various ribbon groups. It is divided into six tabs that are 
grouped by specific categories of cell content 
formatting. You can access the Format Cells dialog box 
by selecting the dialog box launcher in the Font, 
Alignment, or Number group on the Home tab.

Alternatively, you can open the Format Cells dialog box 
by right-clicking a selected cell and then selecting 
Format Cells or by selecting 
Home → Format → Format Cells.



The Format Cells Dialog Box
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Format Cells Dialog Box 
Tab Contains Commands For

Number
Formatting numeric data for a wide variety of purposes. Number formatting 
configures the display and behavior of numbers for figures such as monetary 
amounts, dates, times, percentages, and fractions.

Alignment

Controlling the placement of data within cells. You can use these commands to 
align data with a particular cell border, to center content within a cell, to display 
text at different angles, and to control the relationship between the content and 
the cell borders.

Font
Applying a variety of formatting to your worksheet fonts. You can use these 
commands to change the type, size, and color of your fonts, and to add effects 
such as bolding, underlining, and italics.

Border Applying a variety of formatting to your cell borders. You can use these 
commands to configure the width, color, and style of your cell borders.

Fill Adding color, gradient shading, or patterns as cell backgrounds.
Protection Protecting your cell content.



The Colors Dialog Box
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In addition to the common font colors available from the Font Color drop-down menu, a 
wider range of color options and the ability to customize your font color are available in the 
Colors dialog box. The dialog box is divided into two tabs: the Standard tab and the 
Custom tab. The Standard tab provides you with access to a wide range of preconfigured 
color and grayscale options, whereas the Custom tab lets you customize color options by 
using two different color models. 
In addition to using the Colours 
dialog box to customize your font 
color, you can use it to apply color 
formatting to a number of other 
items, such as cell backgrounds and 
borders. You can access the Colours 
dialog box by selecting More Colours 
from any of the color drop-down 
menus.



Hyperlinks
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A hyperlink is simply a link within a document that, when selected, performs a particular 
action, such as navigating to a different location within the document, opening another 
document, creating a new document, navigating to a web page, or starting an email. In 
Excel 2021, you can create a hyperlink within a worksheet cell or out of an object. When 
you select the text in the cell or the object, Excel performs the designated action. The 
default text formatting for hyperlinks in Excel 2021 is blue, underlined text. You can modify 
the formatting, however, to suit your needs.

When you wish to select a cell containing a hyperlink, it's sometimes a best practice to 
select a nearby cell, and then use keyboard navigation to select it, especially if the text 
spills over into other cells. This is because it's sometimes difficult to select the cell instead 
of the text. When you place the mouse pointer over a cell containing a hyperlink, pay 
attention to the shape of the mouse pointer. If it looks like the standard thick white cross, 
you can select the cell; if it looks like a finger pointing, you can select the hyperlink text.



The Insert/Edit Hyperlink Dialog Box
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You will use the Insert Hyperlink dialog box and the Edit Hyperlink dialog box to create and modify hyperlinks 
in your worksheets.
These are, essentially, the same dialog box; the only differences are that the Insert Hyperlink dialog box 
opens when the active cell does not already contain a hyperlink, and the Edit Hyperlink dialog box opens 
when the active cell contains a hyperlink. The Edit Hyperlink dialog box also displays the Remove Link 
button.
The buttons in the Link to section of the Insert Hyperlink and Edit Hyperlink dialog boxes provide access to 
the various commands and options needed to create, configure, and modify worksheet hyperlinks. You can 
access both of these dialog boxes by selecting Insert → Link.



Dialog Box Element Use This To
Link to section 
buttons

Select the type of hyperlink you wish to create or edit. Selecting each of these will 
display a different set of commands for configuring the hyperlink.

Text to display field
Enter the text you want to display in the cell once you create or edit the hyperlink. If 
there is already text in the cell, Excel automatically displays it here. Any changes you 
make here will overwrite the existing cell text.

ScreenTip button
Open the Set Hyperlink ScreenTip dialog box, which allows you to enter text that 
will appear in a small pop-up box when a user points the mouse pointer at the text 
or object containing the hyperlink.

The Insert/Edit Hyperlink Dialog Box
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The Format Painter
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The Format Painter in Excel 2021 is a tool that simplifies 
applying consistent formatting across multiple cells. It works 
like a paintbrush: you "pick up" the formatting from one cell or 
range and "paint" it onto another, without altering the actual 
content of those cells. All formatting from the source cell is 
applied to the destination cells—you cannot choose specific 
elements to copy. If you double-click the Format Painter, it 
enters sticky mode, allowing you to apply the copied 
formatting to multiple cells until you exit by pressing Esc or 
clicking the icon again. This feature can be used within the 
same worksheet, across different worksheets in a workbook, 
or even in other open workbooks. You can access it from the 
Clipboard group on the Home tab, making it a quick way to 
maintain consistent styling throughout your files.
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Number Formats



The Insert/Edit Hyperlink Dialog Box
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Number formats in Excel control how numeric data is displayed without changing the actual values stored in 
cells. They allow you to present data as currency, dates, times, fractions, decimals, or even highlight negative 
numbers in specific ways. Excel 2021 provides a wide range of preset number formats, along with the option 
to create custom formats tailored to your needs. You can access these settings through the Number tab in 
the Format Cells dialog box, or quickly apply default formats using the Number Format drop-down menu in 
the Number group on the Home tab. This flexibility ensures your worksheets are both accurate and visually 
clear.



Number Format Categories
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Excel 2021's number formatting options are 
arranged by categories, which are grouped 
according to function, for ease of use. The 
following table describes the various number 
formatting categories as displayed on the 
Number tab in the Format Cells dialog box.

The quick-access number formats that are 
available from the Number Format drop-down 
menu are arranged in a slightly different 
configuration of categories.



Number Format Category Enables You To

General Display numeric data in cells exactly as you enter it. This is the default number formatting in Excel worksheets and, 
essentially, applies no specific number formatting to your data.

Number Control how many decimal places are displayed, how negative numbers are displayed, and whether or not Excel uses 
commas to separate degrees of 1,000. 

Currency Control how many decimal places are displayed, whether or not to display currency symbols, and how Excel displays 
negative numbers.

Accounting Control how many decimal places are displayed and whether or not to display currency symbols.

Date
Display dates by using a variety of long and short date formats. Excel uses serial numbers to represent specific dates (0 
represents Dec. 31, 1899; every subsequent number represents the number of days that have passed since then.) This is 
how Excel is able to apply a variety of date formats in your worksheets.

Time
Display times by using a variety of time formats. This can include military time and whether or not to display AM and PM to 
distinguish morning and night time values from each other. Excel uses serial numbers to represent times, much as it does 
with dates. These numbers represent the percentage of the day that has passed since midnight.

Percentage Automatically display numeric values as a percentage and control the number of decimal places that are displayed. 
Basically, this format multiplies the cell value by 100 and adds the percent sign.

Fraction Display decimal values as fractions, control how many digits are displayed in the numerator and the denominator, and 
round non-whole number values to the nearest fraction value.

Scientific Display large numeric values in scientific notation and control the number of decimal places that are displayed.

Text Treat numeric data as textual data. Numbers will be displayed exactly as you enter them but cannot be used in calculations.

Special Display specific numeric data types, such as phone numbers, Social Security numbers, and ZIP codes, in the correct format. 
Special formatting is also useful for working with lists and database tables.

Custom Specify the exact number formatting you require.

Number Format Categories
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Custom Number Formats
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• Custom number formats in Excel allow you to tailor how 
numeric data is displayed when preset options don’t meet 
your needs. 

• They are created using code strings, which you can view 
and modify by selecting the Custom category on the 
Number tab in the Format Cells dialog box. 

• These formats are saved with the workbook file but are not 
available in other workbooks, and you cannot alter Excel’s 
predefined formats—only create copies as custom versions.

In code strings, a zero (0) means a digit will always appear, even if the value is zero, while a number sign (#) 
represents optional digits. For example, entering 3.1000 with the format #.#### displays 3.1, but with 
#.0000 it displays 3.1000. Other symbols, such as dollar signs for currency or commas for thousands 
separators, can also be included to customize how values are presented. This flexibility ensures your data is 
displayed exactly the way you want, without changing the actual values stored in cells.
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Align Cell Contents



Alignment Options

19

Excel 2021 provides you with the ability to control where your content appears horizontally and vertically 
within your worksheet cells. By default, Excel aligns numeric data to the right side and along the bottom of 
worksheet cells, and textual data to the left side and along the bottom of worksheet cells.

Alignment Option Command Button Aligns Text

Top Align Vertically along the top 
of the cell.

Middle Align Centered vertically in 
the cell.

Bottom Align Vertically along the 
bottom of the cell. 

Align Left Horizontally to the left 
side of the cell.

Center Centered horizontally 
in the cell.

Align Right Horizontally to the 
right side of the cell.



Orientation Options
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In order to display data in a worksheet legibly, you may need to change the orientation of 
some of your text. For example, if a column's header text takes up more horizontal space 
than the data in the column's cells, you might want to change the display angle to avoid 
having to make the column too wide. Not only does this make your worksheet layout more 
visually appealing, but it can also help you fit more columns on the same screen or printed 
page. Excel 2021 provides you with a number of preset orientation options. You can also 
specify an exact orientation angle in the Format Cells dialog box from the Orientation 
section on the Alignment tab. Changing cell orientation can affect row height and column 
width.



Orientation Preset Option Description

Angle Counterclockwise Rotates the text in the selected cell or range 45 degrees counterclockwise.

Angle Clockwise Rotates the text in the selected cell or range 45 degrees clockwise.

Vertical Text Orients the text in the selected cell or range vertically from top to bottom, 
but keeps the letters, numbers, and symbols upright.

Rotate Text Up Rotates the text in the selected cell or range 90 degrees counterclockwise.

Rotate Text Down Rotates the text in the selected cell or range 90 degrees clockwise.

Format Cell Alignment Opens the Format Cells dialog box with the Alignment tab automatically 
selected. From here, you can set more precise orientation configurations.

Orientation Options
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You can access the preset orientation options from the Orientation button in the Alignment group 
on the Home tab. These options cannot be used in conjunction with one another, and are not 
configurable. Essentially, you can only toggle these on or off, or switch from one orientation preset 
to another. You can, however, use orientation and alignment options in conjunction with one 
another to achieve the desired text placement.



The Indent Commands
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You can use the indent commands to increase or decrease the amount of space between 
cell data and cell borders. If your cell content is aligned to the left side of cells, selecting 
the Increase Indent command will move the content to the right, increasing the amount of 
space between the left cell border and the content. Selecting the Decrease Indent 
command will move the content to the left. The opposite is true of content aligned to the 
right side of cells.

If your content is centered within the cell, selecting the Decrease Indent command has no 
effect, while selecting the Increase Indent command will automatically change the 
alignment to left aligned and then increase the amount of space between the left border 
and the content.



The Wrap Text Command
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By default, when a cell contains more text than fits its column width, Excel either lets the 
text spill into adjacent empty cells or truncates it if those cells are filled. Neither option is 
ideal for readability. The Wrap Text command solves this by automatically adjusting the 
row height so the text flows onto multiple lines within the same cell, while keeping the 
column width unchanged. This ensures that all content remains visible without disrupting 
the overall worksheet layout, making it easier for users to read and work with large 
amounts of text.



The Merge & Center Options
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In Excel 2021, the Merge Cells feature allows you to combine multiple contiguous cells 
across rows or columns into a single larger cell, and you can later revert them back to 
individual cells. However, merging can affect the data inside those cells—Excel will warn 
you if information may be lost. If you split merged cells back into separate ones, any 
overwritten data cannot be recovered, though you can use the Undo command 
immediately after merging to restore it. This makes merging useful for formatting and 
layout purposes, but it requires caution to avoid losing important content.



Merge & Center Option Description

Merge & Center
Merges all selected cells across rows and columns into a single cell and 
centers the text horizontally in the new, larger cell. Only the data in the 
top-leftmost cell is retained.

Merge Across Merges selected cells together one row at a time. Only the data from 
the leftmost cell in each row is retained and the data is not centered.

Merge Cells Merges all selected cells across rows and columns into a single cell. 
Only the data in the top-leftmost cell is retained and it is not centered.

Unmerge Cells Reverts a merged cell back into the original, individual cells. Data that 
was lost in the merge process is not restored.

The Merge & Center Options

25
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Apply Styles and Themes



Cell Styles
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A cell style in Excel is a predefined or custom set of formatting options that you can apply 
to a cell or range to quickly distinguish common data types, such as totals, labels, or sales 
figures. Styles can include visual formatting like fonts, colors, and borders, as well as 
protection settings to prevent changes to important data. Excel provides a wide variety of 
built-in styles, but you can also create your own to suit organizational needs. You can 
access and apply these options through the Cell Styles command in the Styles group on 
the Home tab, making it easy to maintain consistency and clarity across worksheets.



Galleries
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In Excel 2021, galleries provide a visually oriented 
way to select formatting options. Unlike standard 
drop-down menus that list choices in text, galleries 
display thumbnail previews or icons showing how the 
formatting will look once applied. Most galleries also 
use the Live Preview feature, which temporarily 
shows the effect on selected cells when you hover 
over an option.

For example, when you choose the Cell Styles 
command on the ribbon, Excel opens the Cell Styles 
gallery. This gallery organizes predefined styles into 
functional sections, such as Good, Bad, and Neutral, 
which can be used to highlight performance trends in 
your data. Beyond these built-in styles, you can also 
create custom styles, which then appear in a 
dedicated Custom section of the gallery, giving you 
flexibility to tailor formatting to your specific needs.



The Style Dialog Box
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• You will use the Style dialog box to modify 
existing cell styles and create custom cell styles. 

• The Style dialog box contains a set of formatting 
option check boxes that you can use to quickly 
toggle particular formatting options on and off. 

• From the Style dialog box, you can also access 
the Format Cells dialog box, where you can 
make more detailed changes to your cell styles. 

• You can access the Style dialog box by selecting 
Home→Cell Styles → New Cell Style or by 
selecting Home → Cell Styles, right-clicking an 
existing cell style, and then selecting Modify.



The Merge Styles Dialog Box
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By default, Excel saves custom cell styles with the 
associated workbook file and they are not available 
in other workbooks. 

However, Excel 2021 provides you with a tool you 
can use to import custom styles from existing 
workbooks into other workbooks. 

The Merge Styles dialog box searches all open 
workbook files for custom styles that you can 
merge into the active workbook file. You can access 
the dialog box by selecting Home → Cell Styles → 
Merge Styles.



Themes
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Themes are collections of formatting options that you can apply to an 
entire workbook, as opposed to a particular cell or range. Theme 
formatting includes colors, fonts, and effects but, unlike cell styles, 
does not include number formatting, cell protection, alignment, or fill 
formatting. Several predefined themes are included with Excel 2021, 
and you can manually set the formatting of a workbook and then save 
it as a new custom theme.

You can use Excel themes to create numerous workbooks that all have 
a consistent, professional look. Customizing themes enables you to 
apply organizational branding across all of your spreadsheet 
documents. 

You can access the Themes gallery by selecting 
Page Layout → Themes. 

By default, all new, blank workbooks have the Office theme applied to 
them.

Changing theme formatting does not affect the default text in cells 
without cell styles applied to them.



Theme Components
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Excel themes are made up of colors, fonts, and effects, each 
working together to give worksheets a consistent look. Every 
theme includes a set of 12 colors: 4 for text and backgrounds, 6 
accent colors, and 2 for hyperlinks. The colors shown on the Colors 
button in the Themes group (Page Layout tab) represent the 
current theme’s text and background colors, while the gallery 
reveals accent and hyperlink colors for all available themes, 
including custom ones.

By choosing Page Layout → Colors → Customize Colors, you can 
open the Create New Theme Colors dialog box to adjust and 
preview how each color affects your workbook. Applying different 
themes also changes the available options in the Fill Color and 
Font Color menus, ensuring that your formatting stays consistent 
with the selected theme. In short, theme colors provide a 
structured way to manage the visual identity of your worksheets 
while allowing customization to match organizational or personal 
preferences.



Theme Components
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Theme Color Element Description

Text/Background - Dark 1

Defines the default text color for the workbook. This will be the text 
color for all data displayed in cells unless otherwise formatted, along 
with the color of text displayed on light-colored backgrounds in 
graphical objects such as charts and in cells with light-colored fills.

Text/Background - Light 1 Defines the default color of text displayed on dark backgrounds in 
graphical objects and in cells with dark-colored fills.

Text/Background - Dark 2 Defines the default dark background color for graphical objects.

Text/Background - Light 2 Defines the default light background color for graphical objects.

Accent 1-6 Defines the color of graphical objects such as the individual bars or lines 
on a graph that represent different sets of data.

Hyperlink Defines the default color of hyperlink text for the theme.

Followed Hyperlink Defines the color of hyperlink text once it has been selected.



Theme Components
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Theme FontsAll Excel them
All Excel themes, both pre-existing and custom, contain two fonts: a heading font and a body font. The 
heading font defines the default font type for the Title cell style, and the body font defines the font type for 
labels, titles, and other text on some graphical objects, such as charts. 
• You can access the theme fonts by selecting Page Layout → Fonts. 
• You can also define a set of custom theme fonts by using the Create New Theme Fonts dialog box, which 

you can access by selecting Page Layout → Fonts → Customize Fonts.

• The theme fonts do not affect the default font type for cell data. That is an application-wide setting, 
which is also customizable. The default font type for cell data is Calibri.

Theme Effects
es contain a set of effects that define how graphical elements, such as line styles, line weights, object 
shading, and drop shadows, appear on worksheets. You cannot customize theme effects in Excel, but Excel 
2021 includes a gallery of 15 predefined theme effect configurations. You can access the theme effects by 
selecting Page Layout → Effects.



Custom Themes Considerations
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You have already seen that Excel themes can be customized. But there are a few important 
points to keep in mind when it comes to creating custom themes. The first is that you may 
want to find an existing theme that contains some of the formatting options you desire 
and then make the necessary changes to tweak the theme to suit your needs. This is far 
easier than trying to build one from scratch. Also, Excel saves all themes to a default folder 
that is installed along with Excel. Do not save your custom themes in any other folders. 
Excel will look for custom themes only in the default directory.

Excel enables you to create custom sets of theme colors and custom theme fonts, as well 
as entire custom themes. Each will be displayed at the top of their respective galleries in a 
section called Custom once saved.



Guidelines for Using Themes
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Use Themes
When using themes:
• Apply themes to worksheets whenever possible. It will be more difficult to format a worksheet's data without a theme 

applied.
• Create a custom theme and set each individual element (fonts, colours, effects) to your liking if you don't like any of the 

default themes.
• Remember, it is easier to modify an existing theme than to build one from scratch.
• Keep in mind that themes are meant to facilitate reuse—think of how your themes could enhance future workbooks.
• Remember that all themes need to be stored in the default folder created by Excel.
• Be consistent with themes across worksheets or related workbooks.
• Keep in mind that manually changing the format of data outside of themes will override that theme format. For example, 

if you change the text colour in one cell to red, it will stay red even if you change the theme of the worksheet.
• Make sure that your cell styles work with your themes—if you change a worksheet's theme, it may also alter the 

formatting of any cell styles you have applied.
• Choose colours that blend well together when creating custom themes. Having an excessive amount of disparate colours 

that clash with one another can be eye-straining to your readers.
• Choose disparate colours primarily to highlight specific parts of your data, but keep this to a minimum. Consider the 

saying, "When everything is bold, nothing is."
• Choose an easily readable font at an appropriate size. Large, ornate fonts may be acceptable in worksheet titles, but the 

raw data itself needs to be visually efficient.
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Apply Basic Conditional Formatting



Conditional Formatting
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Using conditional formatting, Excel displays data that meets specified criteria with the specified formatting 
applied. Essentially, data that meets certain conditions you define can stand out from the rest of your data.

For example, on a budget worksheet, you may want all line items that are still under budget to appear in 
green text and line items that are over budget to appear in red text. Or perhaps you want to highlight in 
yellow all product lines on a sales summary that have increased in sales by more than five per cent. 
Conditional formatting can perform these and many other tasks for you.



The Conditional Formatting Dialog Boxes
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Each of the conditional formatting options covered in this topic has its own dialog box. 
These are all basically the same dialog box with a few minor exceptions for option-specific 
considerations. For example, the Between dialog box has two fields for values, whereas the 
Greater Than and Less Than dialog boxes have only a single value field. And, each of the 
dialog boxes is labeled with its corresponding conditional formatting option as the name.

The conditional formatting dialog boxes enable you to select both the criteria by which 
Excel analyzes the selected data and the formatting it will apply. You can select from among 
a small array of preconfigured formatting options or access the Format Cells dialog box to 
configure more specific formatting.



Highlight Cells Rules Option Applies the Selected Conditional Formatting To

Greater Than Cells with values greater than the specified value.

Less Than Cells with values less than the specified value.

Between Cells with values between two specified values.

Equal To Cells with values equal to the specified value.

Text that Contains Cells that contain the exact text or value specified.

A Date Occurring Cells that contain a date that falls within the specified time range.

Duplicate Values Cells in a range that contain the same value as other cells in the selected range.

The Highlight Cells Rules
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Conditional formatting in Excel often involves using Highlight 
Cells Rules to emphasize data that meets specific numeric 
conditions. 
Found under 
Home → Conditional Formatting → Highlight Cells Rules 
This feature lets you set criteria and choose formatting styles for 
matching values. For example, you might highlight cells in green 
when values exceed 250,000, making it easy to spot sales reps 
with quarterly sales above that threshold. This approach draws 
attention to important figures and helps users quickly identify 
trends or outliers in their worksheets.



The Top/Bottom Rules
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Another common use of conditional formatting involves highlighting cells that contain either the highest or 
the lowest values in a particular range or cells that are above or below average for the selected cells. The 
options in the Top/Bottom Rules menu can help you do just that. You can access the Top/Bottom Rules 
menu by selecting Home→ Conditional Formatting → Top/Bottom Rules.
Top/Bottom 
Rules Option Applies the Selected Conditional Formatting To

Top 10 Items The cells in the selected range containing the 10 
largest values.

Top 10% The 10 percent of cells in the selected range 
containing the largest values.

Bottom 10 Items The cells in the selected range containing the 10 
smallest values.

Bottom 10% The 10 percent of cells in the selected range 
containing the smallest values.

Above Average
All cells in the selected range with values that are 
greater than the average of all values in the selected 
range.

Below Average All cells in the selected range with values that are less 
than the average of all values in the selected range.

Presenter
Presentation Notes
The top and bottom 10 and the top and bottom 10-percent criteria are default settings that you can modify when applying conditional formatting to cells. For example, you can conditionally format the top 20 values or the bottom 33 percent of values.



Data Bars
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Data bars are graphical representations of the relative value of data in a range of cells. Data bars appear in 
worksheet cells behind displayed values, giving worksheet viewers an instant picture of where particular cell 
values lie when compared to other cell data. The larger the value is in a particular cell, the longer the data 
bar will be. Excel includes a variety of pre-formatted data-bar styles and provides you with several options for 
customizing their appearance and behavior. You can access the data bars commands and options by selecting 
Home → Conditional Formatting → Data Bars.



Color Scales
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Like data bars, color scales give worksheet viewers a graphical representation of the relative values of cell 
data. Instead of appearing as bars of various lengths, however, color scales use various shades of either two 
or three colors to represent relative values. In a two-color scale, Excel displays high and low values in various 
shades of the two colors; the darker the color, the closer the value is to either the very highest or the very 
lowest values. You can use a three-color scale to represent low-, middle-, and high-range values. Excel 
includes a number of pre-formatted color scales and provides you with various options for customizing these 
to suit your needs. You can access the color scales commands and options by selecting Home → Conditional 
Formatting → Color Scales.



Icon Sets
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Icon sets function in much the same way as data bars and color scales, but they use sets of icons to represent 
relative values. For example, you could use a downward-facing red arrow to represent low values and an 
upward-facing green arrow to represent high values.

• Data bars, color scales, and icon sets appear only in cells that 
contain some type of numeric data, such as values or dates. They 
do not work with text.

• You may have noticed that the primary conditional format options 
are divided into two groups in the Conditional Formatting menu. 
The Highlight Cells Rules and Top/Bottom Rules options both 
compare each individual cell to a condition; the Data Bars, Color 
Scales, and Icon Sets options compare values in cells to each other. 
This is an important distinction between these two groups.
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Create and Use Templates



Templates
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An Excel template is a preconfigured workbook file 
that provides a ready-made structure for creating 
new workbooks. Templates can include formatting, 
formulas, themes, and functions, making them 
useful for quickly setting up consistent files. You can 
download thousands of templates from Office.com 
or other sites, or create your own by building from 
scratch or modifying existing ones.

In Excel 2021, templates use the XLTX file format. 
They are stored in a default folder on your computer 
and can be accessed from the New tab in Backstage 
view. Custom templates remain available on the 
same machine, but you can transfer them to other 
computers or re-download from Office.com if 
needed. Templates save time, ensure consistency, 
and help maintain professional workbook layouts 
across different projects.



Templates and the Backstage View
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In Excel 2021, you can access templates from two main places 
in Backstage view:
• Office tab → Shows new and popular templates from 

Office.com. . You can search, preview, and download 
templates for a wide range of uses. When downloaded, 
they open as standard workbooks. If you want to keep 
them as templates, you must save them locally in the 
template format (.xltx).

• Personal tab → Displays all templates you’ve saved on your 
computer. For them to appear here, they must be stored in 
the default folder: C:\Users\<name>\Documents\Custom 
Office Templates. Templates saved elsewhere won’t show 
up directly in this tab.

The Office and Personal tabs only appear once you’ve either 
downloaded a template or saved a custom one locally. This 
setup makes it easy to switch between ready-made templates 
from Office.com and your own reusable designs.
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